Installationsprobleme mit 16.1

classic Classic list List threaded Threaded
8 messages Options
jochene jochene
Reply | Threaded
Open this post in threaded view
|

Installationsprobleme mit 16.1

Hallo,
ich versuche gerade neben der 14.2 die 16.1 per git zum laufen zu bringen.
Habe mit ein Verzeichnis "Test" angelegt und darin die 16.1 per "git" gezogen.
Nach dem Erzeugen der header.inc.php und der Anmeldung am Setup erscheint in den Logs
Fatal error: Call to undefined function EGroupware\Api\ADONewConnection() in /srv/www/htdocs/xxxxxxxxxx/test/egroupware/api/src/Db.php on line 512
Der Bildschirm bleibt bei der Anmeldung am Setup "leer".
Was bedeutet diese Fehlermeldung?
Vielen Dank
LG
Jochen
Ralf Becker Stylite AG Ralf Becker Stylite AG
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hi Jochen,

Am 07.07.16 um 12:49 schrieb jochene:

> Hallo,
> ich versuche gerade neben der 14.2 die 16.1 per git zum laufen zu bringen.
> Habe mit ein Verzeichnis "Test" angelegt und darin die 16.1 per "git"
> gezogen.
> Nach dem Erzeugen der header.inc.php und der Anmeldung am Setup erscheint in
> den Logs
> Fatal error: Call to undefined function EGroupware\Api\ADONewConnection() in
> /srv/www/htdocs/xxxxxxxxxx/test/egroupware/api/src/Db.php on line 512
> Der Bildschirm bleibt bei der Anmeldung am Setup "leer".
> Was bedeutet diese Fehlermeldung?
Das Du die Installationsanleitung nicht gelesen hast ;-)

    https://github.com/EGroupware/egroupware/blob/16.1/README.md

Es fehlen die diversen Abhänigkeiten die per myrepos Tool dazu zu
installieren sind.

Ralf

> Vielen Dank
> LG
> Jochen

--
Ralf Becker
Director Software Development

Stylite AG

Isaac-Fulda-Allee 9 | Tel. +49 6131 32702-0
D-55124 Mainz       | Fax. +49 6131 32702-70

Email: [hidden email]

www.stylite.de | www.egroupware.org

Managing Directors: Andre Keller | Gudrun Mueller
Chairman of the supervisory board: Prof. Dr. Birger Leon Kropshofer

VAT DE214280951 | Registered HRB 46224 Mainz Germany



------------------------------------------------------------------------------
Attend Shape: An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
Francisco, CA to explore cutting-edge tech and listen to tech luminaries
present their vision of the future. This family event has something for
everyone, including kids. Get more information and register today.
http://sdm.link/attshape
_______________________________________________
egroupware-german mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-german

signature.asc (817 bytes) Download Attachment
jochene jochene
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hi Ralf,

danke für die Info.
Hatte jetzt nicht gedacht, das "myrepos" wichtig sei.

Werde dann mal versuchen für opensue 42.1 ein rpm zu finden. Scheint aber wohl nicht so einfach zu sein.

Schade, das egw nun so "kompliziert" geworden ist.
Wird dann wohl eine längere Nacht werden.

Danke

LG
Jochen
jochene jochene
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hi Ralf,

ich gebe erstmal auf.
Ich möchte mit egroupware, auch wenn nur privat, arbeiten und mich nicht so lange mit Installationen beschäftigen.
Das mit dem "myrepos" erscheint mir auf den ersten Blick erstmal viel zu kompliziert.
Die 14.3 funktioniert ja recht gut, also bleibe ich erstmal dabei, auch wenn ich schon fast alle egw-Versionen mitgemacht habe.
Vielleicht klappt eine zukünftige Installation ja mal leichter.

Auf alle Fälle vielen Dank für die Hilfe.

LG
Jochen
Ralf Becker Stylite AG Ralf Becker Stylite AG
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hi Jochen,

Am 07.07.16 um 20:31 schrieb jochene:

> Hi Ralf,
>
> ich gebe erstmal auf.
> Ich möchte mit egroupware, auch wenn nur privat, arbeiten und mich nicht so
> lange mit Installationen beschäftigen.
> Das mit dem "myrepos" erscheint mir auf den ersten Blick erstmal viel zu
> kompliziert.
> Die 14.3 funktioniert ja recht gut, also bleibe ich erstmal dabei, auch wenn
> ich schon fast alle egw-Versionen mitgemacht habe.
> Vielleicht klappt eine zukünftige Installation ja mal leichter.
Das ist ja auch nicht der normale Installationsweg, sondern der Weg für
eine Entwickler-Installation.

Einfach, schnell und gut upzudaten ist die Installation aus den Paketen:

   
https://software.opensuse.org/download.html?project=server%3AeGroupWare&package=egroupware-epl

Hab' gerade gesehen, dass wir für openSUSE Leap 42.1 noch keine Pakete
bauen, hab' das jetzt mal angeworfen.

Myrepos kann man auch von Github direkt auschecken:

    https://github.com/joeyh/myrepos

Für Debian/Ubuntu und RHEL/CentOS 7 gibt es halt Pakete ...

Ralf

> Auf alle Fälle vielen Dank für die Hilfe.
>
> LG
> Jochen

--
Ralf Becker
Director Software Development

Stylite AG

Isaac-Fulda-Allee 9 | Tel. +49 6131 32702-0
D-55124 Mainz       | Fax. +49 6131 32702-70

Email: [hidden email]

www.stylite.de | www.egroupware.org

Managing Directors: Andre Keller | Gudrun Mueller
Chairman of the supervisory board: Prof. Dr. Birger Leon Kropshofer

VAT DE214280951 | Registered HRB 46224 Mainz Germany



------------------------------------------------------------------------------
Attend Shape: An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
Francisco, CA to explore cutting-edge tech and listen to tech luminaries
present their vision of the future. This family event has something for
everyone, including kids. Get more information and register today.
http://sdm.link/attshape
_______________________________________________
egroupware-german mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-german

signature.asc (817 bytes) Download Attachment
jochene jochene
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hallo Ralf,

nochmals vielen dank für deine Hilfe.

Ich bin schon ein paar Tage älter und froh das ich einen eigenen kleinen privaten Webserver am laufen halten kann.

Als Zusatz habe ich egroupware für mich entdeckt und kam in der Vergangenheit mit svn sehr gut zurecht.
Durch svn war ich bei egw auch immer aktuell.
Das mit dem myrepos erschließt sich mir im Moment nicht so richtig, ist aber auch nicht schlimm.

Wenn es mal ein rpm "myrepos (Opensuse)" gibt, werde ich mich auch bestimmt wieder mit dem neuen egw beschäftigen.

Habe zwar hier http://download.opensuse.org/repositories/server:/eGroupWare:/trunk/openSUSE_Leap_42.1/ ein egw 16.1 für 42.1 gefunden, das installiert sich allerdings nicht dort hin, wo ich es möchte.

Vielleicht komme ich aber auch noch hinter das Geheimnis von myrepos.
Vielleicht habe ich aber auch schon zu viel Tage auf dem Buckel.

Vielen Dank für Deinen Mühen

LG
Jochen
Beliebig Beliebig
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

In reply to this post by Ralf Becker Stylite AG
Hallo Jochen.

Wenn du noch Lust hast, kannste ja mal hier vorbei schauen:
http://webchat.freenode.net/?channels=%23egroupware-de

Bin auch vor kurzem vom SVN auf den git master gewechselt, viell. kann  
ich dir ja ein wenig helfen :)

VG


----------------ursprüngliche Nachricht-----------------
Von:jochene [[hidden email]  ]
An:[hidden email]  Datum:Thu, 7 Jul 2016  
12:16:17 -0700 (MST)
-------------------------------------------------


> Hallo Ralf,
>
> nochmals vielen dank für deine Hilfe.
>
> Ich bin schon ein paar Tage älter und froh das ich einen eigenen kleinen
> privaten Webserver am laufen halten kann.
>
> Als Zusatz habe ich egroupware für mich entdeckt und kam in der
> Vergangenheit mit svn sehr gut zurecht.
> Durch svn war ich bei egw auch immer aktuell.
> Das mit dem myrepos erschließt sich mir im Moment nicht so richtig, ist aber
> auch nicht schlimm.
>
> Wenn es mal ein rpm "myrepos (Opensuse)" gibt, werde ich mich auch bestimmt
> wieder mit dem neuen egw beschäftigen.
>
> Habe zwar hier
>
> http://download.opensuse.org/repositories/server:/eGroupWare:/trunk/
> openSUSE_Leap_42.1/
> ein egw 16.1 für 42.1 gefunden, das installiert sich allerdings nicht dort
> hin, wo ich es möchte.
>
> Vielleicht komme ich aber auch noch hinter das Geheimnis von myrepos.
> Vielleicht habe ich aber auch schon zu viel Tage auf dem Buckel.
>
> Vielen Dank für Deinen Mühen
>
> LG
> Jochen
>
>
>
>
> --
> View this message in context:
> http://egroupware.219119.n3.nabble.com/Installationsprobleme-mit-16-
> 1-tp4013414p4013429.html
> Sent from the egroupware-german mailing list archive at Nabble.com.
>
>
> --------------------------------------------------------------------
> ----------
> Attend Shape:An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
> Francisco, CA to explore cutting-edge tech and listen to tech luminaries
> present their vision of the future. This family event has something for
> everyone, including kids. Get more information and register today.
> http://sdm.link/attshape
> _______________________________________________
> egroupware-german mailing list
> [hidden email]    
> https://lists.sourceforge.net/lists/listinfo/egroupware-german
>





------------------------------------------------------------------------------
Attend Shape: An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
Francisco, CA to explore cutting-edge tech and listen to tech luminaries
present their vision of the future. This family event has something for
everyone, including kids. Get more information and register today.
http://sdm.link/attshape
_______________________________________________
egroupware-german mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-german
jochene jochene
Reply | Threaded
Open this post in threaded view
|

Re: Installationsprobleme mit 16.1

Hallo,

ich schaue dort mal vorbei.

Vielen Dank

LG
Jochen