Major issue upgrading 14.1 to latest

classic Classic list List threaded Threaded
2 messages Options
22ka 22ka
Reply | Threaded
Open this post in threaded view
|

Major issue upgrading 14.1 to latest

Hi Everybody

Our Hosting Provider TMD Hosting tells us that they have tried to upgrade our Egroupware site V. 14.1 to latest, numerous times and cannot get past the following error:

PHP Fatal error: Call to undefined function check_load_extension() in /home/path/domain/egrp/phpgwapi/inc/class.egw_db.inc.php on line 507

This may be related to depreciated modules ie knowledgebase, wiki... we are using under 14.1

Could anyone please give us some idea what the problem is and how we can get past it?

Many thanks in advance.

Kind regards
Gunda


  

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
eGroupWare-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-developers
Ralf Becker-5 Ralf Becker-5
Reply | Threaded
Open this post in threaded view
|

Re: Major issue upgrading 14.1 to latest

Hi Gunda,

Am 06.02.17 um 15:57 schrieb Gunda Wise:

> Hi Everybody
>
> Our Hosting Provider TMD Hosting tells us that they have tried to
> upgrade our Egroupware site V. 14.1 to latest, numerous times and
> cannot get past the following error:
>
> PHP Fatal error: Call to undefined function check_load_extension() in
> /home/path/domain/egrp/phpgwapi/inc/class.egw_db.inc.php on line 507
>
> This may be related to depreciated modules ie knowledgebase, wiki...
> we are using under 14.1
>
> Could anyone please give us some idea what the problem is and how we
> can get past it?
They have not updated correctly.

In 16.1 phpgwapi/inc/class.egw_db.inc.php is only 33 line long, so
there's no line 507. Seems to me phpgwapi is still on 14.1!

For updates NEVER overwrite the existing code with the new archive, it
will leave deleted files in place.

For updating to 16.1 you need the egroupware-epl-compat archive.

Thought you can remove it, after running the update and recreating the
header.inc.php, if you don't use any of the old apps (thought you say
you do).

Ralf

> Many thanks in advance.
>
> Kind regards
> Gunda

--
Ralf Becker
EGroupware GmbH [www.egroupware.org]
Handelsregister HRB Kaiserslautern 3587
Geschäftsführer Birgit und Ralf Becker
Leibnizstr. 17, 67663 Kaiserslautern, Germany
Telefon +49 631 31657-0



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
eGroupWare-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-developers

signature.asc (817 bytes) Download Attachment