Quantcast

Migrating apps to EGroupware 16.1

classic Classic list List threaded Threaded
1 message Options
enver.morina6 enver.morina6
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Migrating apps to EGroupware 16.1

Hello everyone,
i'm developing a EGroupware app and it works well on the old versions from EGroupware,
but now i need to migrate my app to EGroupware 16.
First i tried to install it but it showed to me dependencies error.
As i know EGroupware has changed littel bit it's way how it works.
It is not anymore phpgwapi but now it is api and eTemplate is not compatible anymore

Setupfile dependencies before

$setup_info['test']['depends'][] = array(
                 'appname' => 'phpgwapi',
                 'versions' => Array('14.1')
        );
        $setup_info['test']['depends'][] = array(
                 'appname' => 'etemplate',
                 'versions' => Array('14.1')
        );

Setupfile dependencies now
$setup_info['test']['depends'][] = array(
                 'appname' => 'api',
                 'versions' => Array('16.1')
        );
I changed the setup file and i maded only api depended and it worked.
Now i have installed but it shows me another error

!!! YOU DO NOT HAVE YOUR $GLOBALS['egw_info']['flags']['currentapp'] SET !!!
!!! PLEASE CORRECT THIS SITUATION !!!

Permission denied!
Zugriff verweigert!

Click here to resume your eGroupWare Session.

after i clicked "Click here to resume your eGroupWare Session."  it shows me this

An error happened
CreateObject() file /usr/share/egroupware/api/inc/class..inc.php not found!
Why it doesen't work.
Can anyone answer my Question, i'll appreciate it.
Loading...