New minimum PHP version 5.4: deprecated mysql_pconnect() in cron asyncservices.php

classic Classic list List threaded Threaded
1 message Options
umehner umehner
Reply | Threaded
Open this post in threaded view
|

New minimum PHP version 5.4: deprecated mysql_pconnect() in cron asyncservices.php

Since revision 54145 in trunk EGroupware requires PHP 5.4  instead of 5.3  while recommending 5.6.

I managed to upgrade my Ubuntu 12.04 LTS server to PHP 5.6 (which was quite a nightmare btw).
Since then I get a notification email by every cron job for asyncservices.php with
PHP Deprecated:  mysql_pconnect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /var/www/egroupware2/phpgwapi/inc/adodb/drivers/adodb-mysql.inc.php on line 367

I got rid of it with editing file /var/www/egroupware/phpgwapi/inc/functions.inc.php , line 24 from
error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT);
to
error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED);

Is there any better solution for suppressing those notifications, like in config or php.ini?

Cheers,
Ulle
eGroupware SVN Trunk