Problem bei Installation auf 16.1.20170315

classic Classic list List threaded Threaded
4 messages Options
wingibingi wingibingi
Reply | Threaded
Open this post in threaded view
|

Problem bei Installation auf 16.1.20170315

Hallo zusammen,

bei mir erscheint - scheinbar bereits bei allen vorhergehenden Update im log /root/egroupware-epl-install.log folgendes:

/usr/bin/php7.0 -d memory_limit=-1 /usr/share/egroupware/setup/setup-cli.php --update 'all,admin,4kP%7(30-!gy|TcE,no,etemplate'
EGroupware API Version 16.1.005 gefunden.
EGroupware Konfigurationsdatei (header.inc.php) Version 1.29 existiert und ist aktuell
Datensicherung ausgelassen!
Database error: Invalid SQL: SELECT fs_id,prop_namespace,prop_name,MAX(prop_id) AS prop_id
FROM egw_sqlfs_props
GROUP BY fs_id,prop_namespace,prop_name
HAVING COUNT(*) > 1
Unknown column 'prop_id' in 'field list' (1054)

Was bedeutet das?

Danke im Voraus!

Gruß Wingibingi
Ralf Becker-5 Ralf Becker-5
Reply | Threaded
Open this post in threaded view
|

Re: Problem bei Installation auf 16.1.20170315

Hi Wingibingi,

Am 16.03.17 um 17:47 schrieb wingibingi:

> Hallo zusammen,
>
> bei mir erscheint - scheinbar bereits bei allen vorhergehenden Update im log
> /root/egroupware-epl-install.log folgendes:
>
> /usr/bin/php7.0 -d memory_limit=-1 /usr/share/egroupware/setup/setup-cli.php
> --update 'all,admin,4kP%7(30-!gy|TcE,no,etemplate'
> EGroupware API Version 16.1.005 gefunden.
> EGroupware Konfigurationsdatei (header.inc.php) Version 1.29 existiert und
> ist aktuell
> Datensicherung ausgelassen!
> Database error: Invalid SQL: SELECT
> fs_id,prop_namespace,prop_name,MAX(prop_id) AS prop_id
> FROM egw_sqlfs_props
> GROUP BY fs_id,prop_namespace,prop_name
> HAVING COUNT(*) > 1
> Unknown column 'prop_id' in 'field list' (1054)
>
> Was bedeutet das?
Das bedeutet das Du das Update auf 16.1 ohne das egroupware-epl-compat
Pakete von einer der Vorversionen der letzten 14.3 gemacht hast.
Dann wurde mindestens ein Update, das die prop_id Spalte hinzufügt nicht
durchgeführt.

Was genau Du gemacht hast und von welcher Version kannst Du vermutlich
am besten sagen.

Davon hängt ab, wie Du das jetzt reparieren kannst.

Ralf
 
> Danke im Voraus!
>
> Gruß Wingibingi

--
Ralf Becker
EGroupware GmbH [www.egroupware.org]
Handelsregister HRB Kaiserslautern 3587
Geschäftsführer Birgit und Ralf Becker
Leibnizstr. 17, 67663 Kaiserslautern, Germany
Telefon +49 631 31657-0



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
egroupware-german mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-german

signature.asc (817 bytes) Download Attachment
wingibingi wingibingi
Reply | Threaded
Open this post in threaded view
|

Re: Problem bei Installation auf 16.1.20170315

Ich weiß, dass ich zunächst von 1.8 auf 14 und dann auf 16.1 geupdated habe, aber nicht  welche 14-er Version genau. Was sind denn die Möglichkeiten?

Outlook for Android herunterladen


Von: Ralf Becker-5 [via EGroupware]
Gesendet: Donnerstag, 16. März, 18:10
Betreff: Re: Problem bei Installation auf 16.1.20170315
An: wingibingi

Hi Wingibingi,

Am 16.03.17 um 17:47 schrieb wingibingi:

> Hallo zusammen,
>
> bei mir erscheint - scheinbar bereits bei allen vorhergehenden Update im log
> /root/egroupware-epl-install.log folgendes:
>
> /usr/bin/php7.0 -d memory_limit=-1 /usr/share/egroupware/setup/setup-cli.php
> --update 'all,admin,4kP%7(30-!gy|TcE,no,etemplate'
> EGroupware API Version 16.1.005 gefunden.
> EGroupware Konfigurationsdatei (header.inc.php) Version 1.29 existiert und
> ist aktuell
> Datensicherung ausgelassen!
> Database error: Invalid SQL: SELECT
> fs_id,prop_namespace,prop_name,MAX(prop_id) AS prop_id
> FROM egw_sqlfs_props
> GROUP BY fs_id,prop_namespace,prop_name
> HAVING COUNT(*) > 1
> Unknown column 'prop_id' in 'field list' (1054)
>
> Was bedeutet das?

Das bedeutet das Du das Update auf 16.1 ohne das egroupware-epl-compat
Pakete von einer der Vorversionen der letzten 14.3 gemacht hast.
Dann wurde mindestens ein Update, das die prop_id Spalte hinzufügt nicht
durchgeführt.

Was genau Du gemacht hast und von welcher Version kannst Du vermutlich
am besten sagen.

Davon hängt ab, wie Du das jetzt reparieren kannst.

Ralf
 
> Danke im Voraus!
>
> Gruß Wingibingi

--
Ralf Becker
EGroupware GmbH [www.egroupware.org]
Handelsregister HRB Kaiserslautern 3587
Geschäftsführer Birgit und Ralf Becker
Leibnizstr. 17, 67663 Kaiserslautern, Germany
Telefon +49 631 31657-0

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
egroupware-german mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-german

signature.asc (817 bytes) Download Attachment



If you reply to this email, your message will be added to the discussion below:

http://egroupware.219119.n3.nabble.com/Problem-bei-Installation-auf-16-1-20170315-tp4015313p4015315.html

To unsubscribe from Problem bei Installation auf 16.1.20170315, click here.
NAML

wingibingi wingibingi
Reply | Threaded
Open this post in threaded view
|

Re: Problem bei Installation auf 16.1.20170315

In reply to this post by wingibingi
Hallo Ralf,

ich hatte mir auch den Thread "Upgrade to 16.1.005 prop_id" durchgelesen. Konnte dem aber nicht ganz folgen. Würde es vielleicht bereits reichen, in SQL bei phpmyadmin folgende Zeile einzugeben (habe ich das richtig verstanden)?

ALTER TABLE `egw_sqlfs_props` ADD `prop_id` INT NOT NULL AUTO_INCREMENT, ADD PRIMARY KEY (`prop_id`)

Oder was kann ich sonst tun?

Gruß Wingibingi