Problème egw 1.8 instllation JPgraph

classic Classic list List threaded Threaded
3 messages Options
Gotiep Gotiep
Reply | Threaded
Open this post in threaded view
|

Problème egw 1.8 instllation JPgraph

Bonjour,

Je suis en train d'installer egw 1.8 sur un hébergeur mutualisé 1and1.ca.

J'ai téléchargé le dossier:
http://sourceforge.net/projects/egroupware/files/eGroupware-1.8/eGroupware-1.8.002.20110811/eGroupware-1.8.002.20110811.tar.gz/download

et le dossier:
http://sourceforge.net/projects/egroupware/files/eGroupware-1.8/eGroupware-1.8.002.20110811/eGroupware-egw-pear-1.8.002.20110811.tar.gz/download

J'ai extrait les archives:
egroupware et egw-pear

Je les ai envoyés sur le serveur via FTP.

J,ai crée une base de données sur le serveur.

Puis, j'ai placé le  dossier egw-pear dans le dossier egroupware

J'ai crée un fichier .htaccess à la racine du dossier egroupware, puis j'ai ajouté la ligne:
AddType x-mapp-php5 .php


Enfin j'ai crée un fichier php.ini dans le dossier egroupware/setup/
J'ai écris les lignes:
date.timezone = America/Montreal
upload_max_filesize = 8M
display_errors = OFF
mbstring.func_overload = 7
magic_quotes_gpc = OFF

Là j'ai démarré les test d'installation dans mon browser. J'ai le message d'erreur:
Checking for JPGraph in /homepages/30/d378311631/htdocs/jpgraph: False
You dont have JPGraph version 1.13 or higher installed! It is needed from ProjectManager for Ganttcharts.
Please download a recent version from jpgraph.net/download/ and install it as /homepages/30/d378311631/htdocs/jpgraph.


J'ai déjà cherché un peu partout et la solution semble d'ajouter l'application jpgrap dans le dossier:
egroupware/projectmanager/inc/

Ce que j'ai fait.

Ensuite il semblerait qu'il faille modifier certaines lignes du fichier:
class.projectmanager_ganttchart.inc.php  qui se trouve dans le dossier:
egroupware/projectmanager/inc/

Mais je n'ai pas le même fichier que ce qui est montré dans les forums. Je ne trouve pas les lignes à modifier.
(Exemple d'un site d'explication sur le problème: Look for string “jpgraph-1.5.2″ and then replace it with the name of your new JPGraph (e.g “jpgraph-2.3.4″))

Je ne trouve pas cette fameuse ligne 75 ni même aucun dossier JPGraph-1.5.2 déjà présent dans le dossier egroupware/projectmanager/inc/

Est-il possible que je n'ai pas la bonne version? Ai-je oublié une étape?

Dernière question (Pour ma compréhension) En local, après avoir modifié le php.ini, j'aurais due redémarrer le serveur php pour que les modifications s'activent, pourquoi pas en mutualisé?

Merci d'avance pour vos réponses, je suis bloqué depuis deux jours sur jpgrap...


Guillaume35 Guillaume35
Reply | Threaded
Open this post in threaded view
|

Re: Problème egw 1.8 instllation JPgraph

Bonjour,

J'ai installé EGW sur 1and1.fr pas plus tard que vendredi dernier.

Tu as en effet besoin du module EGW (core) et egw-pear, télécharge en plus le module jpgraph (dispo sur sourceforge).

copie ses 3 fichiers (tar.gz) directement à la racine de ton site.
extrait les 2 fichiers EGW, tu devrais avoir un repertoire /egroupware
extrait le fichier jpgraph et renomme le dossier jpgraph
supprime le .htaccess si il existe
crée un fichier php.ini (avec les specs de EGW) dans le repertoire /egroupware
utilise un script de copie du php.ini dans tous les repertoires et sous repertoires (voir FAQ 1and1).
assures-toi que la BDD est bien crée et fonctionnelle.
et tu peux démarrer l'installation ...

Bon courage
Guillaume
Guillaume - Egroupware 1.8.002 (1and1)
fanny fanny
Reply | Threaded
Open this post in threaded view
|

Re: Problème egw 1.8 instllation JPgraph

In reply to this post by Gotiep
Cher Gotiep
Je suis en train d'installer egroupware 1.8
J'ai fait les mêmes premieres manip, sauf que en plus d'avoir rajouté la  ligne dans htaccess,  j'ai laissé ce qu il y avait, ce qui me donne un htaccess comme suit :

php_flag file_uploads on
php_flag log_errors on
php_flag magic_quotes_gpc off
php_flag magic_quotes_runtime off
php_flag register_globals off
php_flag short_open_tag on
php_flag track_vars on
php_flag display_errors off
# E_ALL & ~E_NOTICE & ~E_STRICT = 8191 - 8 - 2048 = 6135
php_value error_reporting 6135
php_value max_execution_time 90
php_value memory_limit 256M
php_value session.gc_maxlifetime 14400
php_value upload_max_filesize 64M
php_value post_max_size 65M
# session handling: now the check for expired sessions is done on every 10th session creation
php_flag session.use_trans_sid Off
php_value session.gc_probability 1
php_value session.gc_divisor 10
# multibyte extension: needed for utf-8
php_value mbstring.func_overload 7
AddType x-mapp-php5 .php

J'ai aussi rajouté le php.ini

Malheureusement, j ai toujours ce &&&&&& message d'erreur :
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webadmin@kundenserver.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the reque

avez vous une idée?

merci
fanny