Re: [eGroupWare-users] The following From address failed

classic Classic list List threaded Threaded
1 message Options
David C. Rankin David C. Rankin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [eGroupWare-users] The following From address failed

Ralf Becker wrote:

> Hi David,
>
> this can have many reasons: in my case ([hidden email])
> it could be eg. the graylisting, which rejects the first delivery.
>
> I dont think it's a general issue and I cant help everyone using eGW :-(
>
> If you need professional support, please go to www.egroupware-support.eu
>
> Hoping for your understanding
>
> Ralf
>
> David Rankin schrieb:
>> Hi David,
>>
>> there's a fixed timeout in phpgwapi/inc/class.phpmailer.inc.php Line 194:
>>
>>     var $Timeout      = 10;
>>
>> I had to set it in some installations to a higher value, maybe that's
>> your problem too.
>>
>> Ralf
>>
>> David Rankin schrieb:
>>
>>>> Dave,
>>>>
>>>> This is a **HUGE** bug and problem that has been around since 1.2.00x
>>>> Everyone get this error using felamimail in my office.  What is funny is if
>>>> after you get the message, you hit send again and it will send the mail or
>>>> time out. If it times out and give the same error a 2nd time, hit send again
>>>> and the message **will** go out. I have posted this error numerous times, but
>>>> it still has not been fixed. We end up using Outlook to send mail and use
>>>> egroupware for everything else....
>>>>
>>>> Maybe it will get addressed and fixed this time...
>>>>
>>>>
>>>> David C. Rankin, J.D., P.E.
>>>> Rankin Law Firm, PLLC
>>>> 510 Ochiltree Street
>>>> Nacogdoches, Texas 75961
>>>> (936) 715-9333
>>>> (936) 715-9339 fax
>>>> www.rankinlawfirm.com <http://www.rankinlawfirm.com/>
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: [hidden email] <mailto:[hidden email]>
>>>> [mailto:[hidden email]] On Behalf Of dave5
>>>> Sent: Monday, August 27, 2007 2:47 PM
>>>> To: [hidden email] <mailto:[hidden email]>
>>>> Subject: [eGroupWare-users] The following From address failed
>>>>
>>>>
>>>> Came in to work after the weekend and no one can send emails. Viewing and
>>>> everything else still works perfectly. Nothing was updated on the server
>>>> over the weekend, so I'm stumped.
>>>>
>>>> I'm running Exim4 which can still send emails via command line or using
>>>> Mozilla Thunderbird, but Egroupware returns the error "The following From
>>>> address failed" followed by the users email address. This is happening for
>>>> all users in all instances.
>>>>
>>>> the Exim4 mainlog reads,
>>>>
>>>> SMTP protocol synchronization error (input sent without waiting for
>>>> greeting): rejected connection f
>>>> rom H=[xxx.xxx.xxx.xxx] U=www-data input="EHLO xxxx.xxxxxx.xxx\r\nHELO
>>>> xxx.xxxxx.xxx\r\n"
>>>>
>>>> If I force exim4 to ignore the greeting (smtp_enforce_sync=false) I get the
>>>> follow error in the logs.
>>>>
>>>> SMTP connection from (xxxx.xxxxxxx.xx) [xxx.xxx.xxx.xxx] lost while reading
>>>> message data (after header)
>>>>
>>>> Any thoughts,
>>>> thanx
>>>> --
>> --
>> Ralf Becker
>>
>> ---------------------------
>> ****** PRIVATE EMAIL ******
>>
>> ---------------------------
>>
>>
>> Direct to Ralf,
>>
>>
>> It is not fixed for our SuSE 10.0 setup or out Mandriva 2006 setup. Both
>> servers fail to send with the first try giving the message discussed
>> here. This message is beind send from my 3111skyline.com setup and it
>> will probably fail the first time I try.
>>
>> "Yep it failed again on the first send attempt with the error of:
>>
>> *SMTP Error: The following recipients failed:
>> [hidden email]*
>>
>> I have given you and Lars full admin accounts on the 3111skyline.com
>> install to let you see the error we get trying to send mail and to
>> hopefully get it resolved. Your account is "ralf" and you p.w. is
>> "beckeregw1". Lars is "lars" and "kneschke". The are active until 9/30
>>
>>
>>
>> I would really like to try and get this solved as a big part of egw is
>> unuasable in my opensuse 10.0 and mandrive 2006le setup.
>>
>>
>>
>> Let me know what else I can do or provide you with to help get the smtp
>> error fixed.
>>
>> ------------------------------------------------------------------------
>>
>> David C. Rankin, J.D., P.E.
>> Rankin Law Firm, PLLC
>> 510 Ochiltree Street
>> Nacogdoches, Texas 75961
>> (936) 715-9333
>> (936) 715-9339 fax
>> www.rankinlawfirm.com
>>
>

Ralf,

        I apologize, the $Timeout 30; class.phpmailer.inc.php seems to have
worked. One observation for usability; Is there any way to background
the message after the [send] button has been pressed and only pop it
back up in case of an error??  Right now the user just stares at the
mail they have thought they have sent for 20 seconds wondering what is
happening.

        Also, a default $timeout of 30 might cure a lot of problems...


--
David C. Rankin, J.D., P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
(936) 715-9333
(936) 715-9339 fax
www.rankinlawfirm.com

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
eGroupWare-usability mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/egroupware-usability
Loading...